Wing Python IDE 6.1.4: January 16, 2019

Wingware has released version 6.1.4 of its family of cross-platform Python IDEs.

Changes in 6.1.4

This minor release fixes using typing.IO and similar classes as type hints, improves handling of editor splits in goto-definition, fixes failure to install the remote agent, and fixes failure to convert EOLs in the editor. See the change log for details.

Download Now

About Wing

Wingware's family of cross-platform Python IDEs make Python development easier, with powerful integrated editing, debugging, unit testing, and project management features. Wing runs on Windows, Linux, and OS X, and can be used to develop any kind of Python code for web, desktop, scientific, data analysis, embedded scripting, and other applications.

Version 6 introduces many new features, including improved multi-selection, much easier remote development, debugging from the Python Shell, recursive debugging, PEP 484 and 526 type hinting, PEP 8 reformatting, support for Python 3.6 and 3.7, ability to create a new virtualenv from the New Project dialog, improved VI mode, support for Vagrant, Jupyter, Django 1.10+ and 2.0, and Windows Subsystem for Linux, improved support for matplotlib, easier Raspberry Pi development, optimized debugger, OS X full screen mode, One Dark color palette, Russian localization (thanks to Alexandr Dragukin), expanded free product line, and much more. For details, see What's New in Wing Version 6.

Wing 6 works with Python versions 2.5 through 2.7 and 3.2 through 3.7, including also Anaconda, ActivePython, EPD, Stackless, and others derived from the CPython implementation.

Wing Pro requires purchasing or upgrading a license, or obtaining a 30-day trial at startup. Wing 101 and Wing Personal are free versions that omit some features.

For more information, please visit wingware.com

Upgrading

You can try Wing 6 without removing older versions. Wing 6 will read and convert your old preferences, settings, and projects. Projects should be saved to a new name since previous versions of Wing cannot read Wing 6 projects.

See also Migrating from Older Versions and Upgrading.